WR703N刷Openwrt+Mentohust实现锐捷认证

in Shares with 14 comments

最近办理了校园网,学校用的锐捷认证,版本4.60.
学校的认证程序限制了多网卡,这简直是噩梦,虽然说用猎豹WIFI可以破解,但是总归不是个根治的好方法.
于是打算买个路由器刷Openwrt,用Mentohust进行认证,方便多设备上网.

路由器选择

考虑良久后选择了TP-LINK WR703N
其优点如下:体积小,可MicroUSB供电(这个绝对赞,寝室晚上断电,有了这货再也不用担心晚上就没网用了),可挂载U盘(当然你也插个小风扇给路由散热2333),价格便宜(70-120不等)

刷路由器Openwrt&&配置

1.703N固件(带LuCi):http://pan.baidu.com/s/1hqBsOeS 密码:2d2m
2.Mentohust(mips):http://pan.baidu.com/s/1dDznEVJ 密码:hbz9
3.winscp(用于传文件):http://pan.baidu.com/s/1kT7OSyr 密码:x3jq
刷固件在路由器的管理页面系统工具->软件升级处,然后上传固件,点击升级就行,注意这个过程千万别断电,否则就成砖了.

初始配置

和平时路由器差不多,设置好自己的密码和无线安全的相关信息,图片仅供参考,在此就不赘述了.
QQ截图20141015220133 QQ截图20141015220155 QQ截图20141015220225
注意这里桥接不要设置错了,只有接口LAN需要创建桥接,接口为你的WIFI,接口WAN不需要创建桥接。否则会陷入回路连不上WIFI网线也连不上,重置路由才能解决。

网络配置

修改/etc/config/network
以下是我的设置,可以参考一下

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config interface 'wan'
	option ifname 'eth0'
	option _orig_ifname 'eth0'
	option _orig_bridge 'false'
	option proto 'static'
	option ipaddr '10.10.XX.XX' #学校指定的IP
	option netmask '255.255.255.0'
	option gateway '10.10.XX.XX' #学校分配的网关
	option macaddr '20:6A:8A:46:XX:XX' #你账号绑定的MAC地址(有的学校可能不需要)
	option dns '210.30.XX.7 210.XX.48.8 8.8.8.8 8.8.4.4' #自定义的DNS

修改后执行/etc/init.d/network restart

Mentohust及其配置

使用WinScp将刚刚下载的mentohust复制至/usr/bin处

这时你会发现mentohust是没有执行权限的,我们执行chmod +x /usr/bin/mentohust即可解决
如果发现提示文件不存在那么cd至bin目录下再执行chmod +x mentohust亦可
加了执行权限后应该是这样的
QQ截图20141016155219

mentohust认证命令
mentohust -u用户名 -p密码 -neth0 -i学校分配的IP -m子掩网码 -g学校分配的网关 -l0 -a1 -d0 -b3(这是我使用的)
这里有一个问题,本来在WAN口设置了指定的IP、DNS相关参数后再在mentohust命令下是不用二次指定的,但是我一直没有成功,尝试指定后却成功了,一直很困惑.懒的找原因了.以后再摸索摸索是什么问题.
连接后的日志可以在/tmp/mentohust.log查看
mentohust -h可以获取相关命令帮助
也可以去https://code.google.com/p/mentohust/wiki/Parameter

完结

有WIFI的感觉真是好~

Responses
  1. 表示锐捷5.20模拟发包也不能在路由器上认证

    Reply
  2. O(∩_∩)O~

    我学校6.43怎么办

    Reply
    1. @O(∩_∩)O~

      我们好像也是6.43.。。但5.20也可以用

      Reply
  3. Simon Zhong

    请问你学校的锐捷版本是多少呢?

    Reply
    1. Reply
      1. Simon Zhong
        @予而不语

        我们的都5.2l

        Reply
  4. NGY

    楼主,请问Netgear WNDR4300刷了Openwrt后能用你编译的这个Mentohust吗?谢谢。

    Reply
    1. @NGY

      可以的,不过版本好像略微不同,如果这个不可用及时找我,我把我正在用的给你。

      Reply
      1. Chita
        @予而不语

        你好,方便的话可否把你目前正在用的mentohust发给我一份呢?zhouzhida_1997@outlook.com 谢谢!

        Reply
        1. @Chita

          已发送

          Reply
          1. Chita
            @予而不语

            看到了,谢谢!

            Reply
      2. NGY
        @予而不语

        才看到,谢谢。怕不能用最后还是入了hiwifi。

        Reply
  5. mentohust这玩意现在还能用也是很惊奇的了,开发者早已毕业于是就撒手不管了,新版据说是用不了的,不过可能是你们学校用的还是老版本锐捷吧。然而某宝上确有卖新版锐捷可用的路由,软件闭源,每个机器软件是与机器上Flash的一个编号独立绑定的因此编程器复制后也无法使用。路由黑科技普遍认为来源于锐捷内部人员。

    Reply
    1. @dommyet

      学校用的确实是旧版的,新版锐捷没有了解过,不过还是觉得应该能通过模拟发包来实现,但自己没那技术,留给别人去做,会用就很满足了。

      Reply